Re: [cisco-ttl] QOS CALISTIRAMADIM ACİL YARDIM LUTFEN

From: Ahmet TOMBAK <ahmet.tombak_at_....>
Date: Sat Mar 31 2007 - 21:35:59 CEST


SIP altında hangi codec kullanıyorsun ?
frame relay interfaceler altında RTP compression aktif edersen ve birde en son olarak LLQ aktif edersen problemini halledebilirsin. Sesde kalite sağlamak için en son jitter bufferını biraz artır. görüşme ilk başladığı zaman çok az bir geçikme ile başlar ama daha sonra kaliteli devam eder.

rtp için aşağıdaki linkten faydalanabilirsin.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart6/qcrtphc.htm

Selam
Ahmet

On 3/30/07, cumhuraltan <cumhuraltan@yahoo.com.tr> wrote:
> Selamlar Arkadaşlar Merkez de ve ŞUBE de QoS komutlarını
> uygulamama ragmen ses de kesılmeler olmakta nerde yanlıs
> yapıyorum acaba öncelıkle yaptıgım işlemler ozetlıyeyım
>
> Öncelıklı olarak access-listler olusturdum
>
> 101 ses için 102 de sinyalleşme için sip kullanılmakta
>
> access-list 101 permit udp any any
> access-list 102 permit udp any any eq 5060
> access-list 102 permit tcp any any eq 5060
>
> Daha sonra class ları olusturup access-group ları atadım
>
> class-map match-all voice
> match access-group 101
>
> class-map match-all signal
> match access-group 102
>
> Daha Sonra Policy olusturdum 128 bandwitdh ben voice için 96 ayırdım
> ses oncelıklı cunku gorusme yapılırken data transferı dursa
> bıle sorun degıl
>
> policy-map policy
> class voice
> priority 96
> class signal
> priority 8
> class class-default
> fair-queue
>
> Daha Sonra map class olusturdum
>
> map-class frame-relay 128
> frame-relay cir 128000
> frame-relay bc 1280
> frame-relay be 0
> frame-relay mincir 128000
> service-policy output policy
> frame-relay fragment 160
> access-list 101 permit udp any any
> access-list 102 permit udp any any eq 5060
> access-list 102 permit tcp any any eq 5060
>
> Sonra Seri interface ın altında shapping i aktifleştirdim
>
> interface Serial0/0
> description FRAME-RELAY HUB
> bandwidth 128
> no ip address
> encapsulation frame-relay
> invert txclock
> frame-relay traffic-shaping
> frame-relay lmi-type ansi
>
> Daha Sonra sub interface in "Serial 0/0.1 point-to-point" altında
>
> frame relay interface-dlci 16 komutu ile dlci içine girdim
> ve "class 128" komutu ile class ı interface e atadım
>
> interface Serial0/0.1 point-to-point
> description connected to MERKEZ
> bandwidth 128
> ip unnumbered Loopback0
> frame-relay interface-dlci 16 CISCO
> class 128
>
> aşagıda mevcut running conf ları ve frame relay pvc leri aşagıda
> gonderıyorum
>
> Öncelikli olarak sube conf u
>
> Building configuration...
>
> Current configuration : 7425 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname p
> !
> logging queue-limit 100
> enable secret
> !
> ip subnet-zero
> !
> !
> ip dhcp excluded-address 192.168.25.2
> ip dhcp excluded-address 192.168.25.3
> ip dhcp excluded-address 192.168.31.2
> ip dhcp excluded-address 192.168.31.3
> !
> ip dhcp pool MGZPOOL
> network 192.168.25.0 255.255.255.0
> dns-server 192.168.0.102
> default-router 192.168.25.1
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> no voice hpi capture buffer
> no voice hpi capture destination
> !
> !
> mta receive maximum-recipients 0
> !
> !
> class-map match-all sinyal
> match access-group 102
> class-map match-all signal
> match access-group 102
> class-map match-all voice
> match access-group 101
> class-map match-all ses
> match access-group 101
> !
> !
> policy-map policy
> class voice
> priority 96
> class signal
> priority 8
> class class-default
> fair-queue
> !
> !
> !
> interface Loopback0
> ip address 172.10.25.1 255.255.255.255
> delay 10
> !
> interface FastEthernet0/0
> ip address 192.168.25.1 255.255.255.0
> speed auto
> !
> interface Serial0/0
> description FRAME-RELAY HUB
> bandwidth 128
> no ip address
> encapsulation frame-relay
> invert txclock
> frame-relay traffic-shaping
> frame-relay lmi-type ansi
> !
> interface Serial0/0.1 point-to-point
> description connected to MERKEZ
> bandwidth 128
> ip unnumbered Loopback0
> frame-relay interface-dlci 16 CISCO
> class 128
> !
> router eigrp 100
> network 172.10.25.1 0.0.0.0
> network 192.168.25.0
> no auto-summary
> no eigrp log-neighbor-changes
> !
> ip classless
> no ip http server
> !
> !
> !
> !
> map-class frame-relay 128
> frame-relay cir 128000
> frame-relay bc 1280
> frame-relay be 0
> frame-relay mincir 128000
> service-policy output policy
> frame-relay fragment 160
> access-list 101 permit udp any any
> access-list 102 permit udp any any eq 5060
> access-list 102 permit tcp any any eq 5060
> !
> call rsvp-sync
> !
> voice-port 1/0
> cptone TR
> !
> voice-port 1/1
> cptone TR
> !
> !
> mgcp profile default
>
>
> VE BUDA mevcut frame relay goruntusu
>
> p#sh frame-relay pvc 16
>
> PVC Statistics for interface Serial0/0 (Frame Relay DTE)
>
> DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
> Serial0/0.1
>
> input pkts 3324 output pkts 7030 in bytes 328135
> out bytes 1774197 dropped pkts 16 in pkts dropped 16
> out pkts dropped 0 out bytes dropped 0
> in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
> out BECN pkts 0 in DE pkts 0 out DE pkts 0
> out bcast pkts 311 out bcast bytes 26898
> 5 minute input rate 0 bits/sec, 0 packets/sec
> 5 minute output rate 0 bits/sec, 0 packets/sec
> pvc create time 00:22:48, last time pvc status changed 00:21:48
> service policy policy
> Serial0/0.1: DLCI 16 -
>
> Service-policy output: policy
>
> Class-map: voice (match-all)
> 5197 packets, 337663 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: access-group 101
> Queueing
> Strict Priority
> Output Queue: Conversation 24
> Bandwidth 96 (kbps) Burst 2400 (Bytes)
> (pkts matched/bytes matched) 5197/337663
> (total drops/bytes drops) 0/0
>
> Class-map: signal (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: access-group 102
> Queueing
> Strict Priority
> Output Queue: Conversation 24
> Bandwidth 8 (kbps) Burst 200 (Bytes)
> (pkts matched/bytes matched) 0/0
> (total drops/bytes drops) 0/0
>
> Class-map: class-default (match-any)
> 1833 packets, 1384482 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> Queueing
> Flow Based Fair Queueing
> Maximum Number of Hashed Queues 16
> (total queued/total drops/no-buffer drops) 0/0/0
> Output queue size 0/max total 600/drops 0
> fragment type end-to-end fragment size 160
> cir 128000 bc 1280 be 0 limit 160 interval 10
> mincir 128000 byte increment 160 BECN response no IF_CONG no
> frags 14984 bytes 1774197 frags delayed 9108 bytes
> delayed 1403687
>
> shaping inactive
> traffic shaping drops 0
>
>
>
> MERKEZ IN CONF U
>
> uilding configuration...
>
> Current configuration : 24064 bytes
> !
> version 12.2
> service timestamps debug datetime msec localtime
> service timestamps log datetime msec
> service password-encryption
> service sequence-numbers
> !
> hostname M
> !
> logging buffered 32000 debugging
> logging cns-events debugging
> enable secret
>
> voice-card 2
> !
> ip subnet-zero
> !
> !
> ip host Akmerkez 172.10.63.1
> !
> !
> class-map match-all signal
> match access-group 103
> match access-group 112
> class-map match-all voice-signaling
> match access-group 103
> class-map match-all Ses
> match access-group 104
> class-map match-all voice
> match access-group 111
> !
> !
> policy-map QoS-Voice
> class signal
> bandwidth 1024
> class Ses
> set ip dscp ef
> priority 45
> class voice-signaling
> bandwidth 32
> class class-default
> fair-queue
> policy-map policy
> class voice
> priority 96
> class signal
> priority 8
> class class-default
> fair-queue
> !
> isdn switch-type primary-net5
> !
> !
> voice call send-alert
> voice call carrier capacity active
> !
>
> interface Loopback0
> ip address 172.10.0.1 255.255.255.255
> !
> interface FastEthernet0/0
> ip address 84.44.88.117 255.255.255.252 secondary
> ip address 192.168.0.2 255.255.255.0
> duplex auto
> speed auto
> !
> interface Serial0/0
> description MERKEZ FRAME-RELAY HUB
> bandwidth 2048
> no ip address
> encapsulation frame-relay IETF
> frame-relay traffic-shaping
> frame-relay lmi-type ansi
> ip rsvp bandwidth 1536 1536
> !
>
> !
> interface Serial0/0.25 point-to-point
> description connected to profilostore
> bandwidth 128
> ip unnumbered Loopback0
> no ip mroute-cache
> frame-relay interface-dlci 36 CISCO
> class 128
>
> i
> !
> interface FastEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
> !
> interface Serial0/1
> description connected to BEBEK
> bandwidth 512
> ip address 172.10.250.1 255.255.255.252
> !
> interface Serial0/2
> ip address 50.0.0.2 255.255.255.252
> clockrate 125000
> !
> interface Serial0/3
> no ip address
> clockrate 125000
> !
> interface Serial2/0:15
> no ip address
> no logging event link-status
> isdn switch-type primary-net5
> isdn incoming-voice voice
> isdn send-alerting
> no cdp enable
> !
> router eigrp 100
> redistribute static
> network 172.10.0.1 0.0.0.0
> network 172.10.0.0
> network 192.168.0.0
> auto-summary
> no eigrp log-neighbor-changes
>
> !
> !
> !
>
>
> map-class frame-relay 128
> frame-relay fragment 160
> frame-relay cir 128000
> frame-relay bc 1280
> frame-relay be 0
> frame-relay mincir 128000
> service-policy output policy
> access-list 103 permit tcp any eq 1720 any
> access-list 103 permit tcp any any eq 1720
> access-list 104 permit ip 84.44.88.112 0.0.0.7 any
> access-list 111 permit udp any any
> access-list 112 permit udp any any eq 5060
> access-list 112 permit tcp any any eq 5060
>
> MERKEZ IN PVC GORUNTUSU
>
> M#sh frame-relay pvc 36
>
> PVC Statistics for interface Serial0/0 (Frame Relay DTE)
>
> DLCI = 36, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
> Serial0/0.25
>
> input pkts 6309 output pkts 3459 in bytes 1336095
> out bytes 355815 dropped pkts 758 in pkts dropped
> 758
> out pkts dropped 0 out bytes dropped 0
> in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
> out BECN pkts 0 in DE pkts 0 out DE pkts 0
> out bcast pkts 345 out bcast bytes 29892
> 5 minute input rate 1000 bits/sec, 2 packets/sec
> 5 minute output rate 0 bits/sec, 0 packets/sec
> pvc create time 00:26:40, last time pvc status changed 00:24:00
> fragment type end-to-end fragment size 160
> cir 128000 bc 1280 be 0 limit 160 interval 10
> mincir 128000 byte increment 160 BECN response no IF_CONG no
> frags 4365 bytes 355815 frags delayed 1126 bytes
> delayed 163022
>
> shaping active
> traffic shaping drops 0
> service policy policy
> Serial0/0.25: DLCI 36 -
>
> Service-policy output: policy
>
> Class-map: voice (match-all)
> 1966 packets, 130715 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: access-group 111
> Queueing
> Strict Priority
> Output Queue: Conversation 24
> Bandwidth 96 (kbps) Burst 2400 (Bytes)
> (pkts matched/bytes matched) 1966/130715
> (total drops/bytes drops) 0/0
>
> Class-map: signal (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: access-group 103
> Match: access-group 112
> Queueing
> Strict Priority
> Output Queue: Conversation 24
> Bandwidth 8 (kbps) Burst 200 (Bytes)
> (pkts matched/bytes matched) 0/0
> (total drops/bytes drops) 0/0
>
> Class-map: class-default (match-any)
> 1495 packets, 220116 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> Queueing
> Flow Based Fair Queueing
> Maximum Number of Hashed Queues 16
> (total queued/total drops/no-buffer drops) 3/0/0
> Output queue size 3/max total 600/drops 0
>
>
>
>
>
> --
> Cisco Teknik Tartisma Listesi (Cisco-ttl)
>
> Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk
> kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da
> bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
> Yahoo! Groups Links
>
>
>
>

--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/cisco-ttl/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/cisco-ttl/join
    (Yahoo! ID required)

<*> To change settings via email:
    mailto:cisco-ttl-digest@yahoogroups.com 
    mailto:cisco-ttl-fullfeatured@yahoogroups.com

<*> To unsubscribe from this group, send an email to:
    cisco-ttl-unsubscribe@yahoogroups.com

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 
Received on Sun Apr 1 18:18:35 2007

This archive was generated by hypermail 2.1.8 : Sun Apr 01 2007 - 18:18:35 CEST