[cisco-ttl] g.shdsl (cisco878) frame-relay (cisco1700) voip configuration

From: ducatisenna2002 <racer_rs3_at_....>
Date: Sun Nov 19 2006 - 17:09:19 EET


Merhaba,

serhan sezgin ben, cablenette calisiyorum, network konusunda yardiminiza ihtiyacim var, anlayamadigim birsey var,

bir firmanin iki lokasyonu birbirine iç networkten bagli sairnigarda(cisco878) ve kurtulus depoda(cisco1700) routerlar var, bu routerlar uzerinde 128 k lik voice trafigi icin bandwidth ayirilacak, frame relaydakini cisco configmakerdan deneyerek su sekilde buldum. attachmentlardaki framerelayqosconf.txt dosyasinda ustte yazdigi gibi

frame-relay ip rtp header-compression
 ip rtp reserve 16384 100 256
 traffic-shape rate 2048000 256000 256000
!

bu sekilde 256 k lik bir voice trafigi reserve ettim, dogru olarak calisir mi?

attachmentlardaki framerelayqosconf.txt dosyasinda altta yazan car komutlarinida boyle yaptim
bunun voice icin olanini bulamadim.

 !
 ! Committed Access Rate (CAR)
 !

 rate-limit output access-group 100 512000 8000 8000 conform-action set-prec-continue 2 exceed-action drop
 rate-limit output access-group 101 64000 6000 6000 conform-action set-prec-continue 3 exceed-action drop
 rate-limit output access-group 102 32000 8000 8000 conform-action set-prec-continue 4 exceed-action drop
!
!
!
! Access Control List 100
!

no access-list 100
access-list 100 permit tcp any any eq www
!
! Access Control List 101
!

no access-list 101
access-list 101 permit tcp any any eq telnet
!
! Access Control List 102
!

no access-list 102
access-list 102 permit tcp any any range ftp-data ftp

frame-relay daki 2 Mbitlik bandwidth, 256 klik voip ve car komutlarini ciscoconfig makerda bir frame relay baglanti yapip onun arayuzunden ayarlayip, ios configurasyonunda de&#287;i&#351;tirdi&#287;i komutlara gore gordum. g.shdsl uzerine bir 878 routerda bunu deneme firsatim olamadi, mimicten virtual router download etmek istedim ama daha maili gelmedi. boson v6.2 dede bulamadim g.shdsl i yardimci olursaniz sevinirim.

ciscoata-cisco1700-frame-relay-TT Bulutu-g.shdsl-cisco878-ciscoata

                    |                                |
                    -------Lease Line-----------------

cisco 1700 2 Mbit hat 128 voice trafigi ve cisco 878 1 Mbit hat 128 k voice trafigi
bandwidth ve qos tanimlarini yapmam lazim frame-relayi buldum gibi bir kontrol edebilir misiniz, ama
g.shdsl i bulamadim.

kurtulus depoda ki
interface Serial0.1 point-to-point
 description Connection to G.SHDSL Link SairNigar  ip address 10.10.11.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 34
frame-relay ip rtp header-compression
 ip rtp reserve 16384 100 256
 traffic-shape rate 2048000 256000 256000

calisirmi ve sairnigardaki g.shdsl i nasil yapacagim qos i ve bandwidth i

sdm kurdum ama baglanip kontrol edecek router ip si ve sifresi bilmiyorum.bir cisco 878 olsa g.shdsl e bagli sdm ile denerim ama yok, outsource verdigimiz bir firmaya gidip yapip cikmam lazim.

baglanabilecek router ip si biliyorsaniz sdm i denemek istiyorum.

sdm le 878 de g.shdsl in voip confunu ve 1700 un frame-relay daki voip confunu sorunsuz yapabilir miyim.

ekteki sairnigar in configurasyonuna cisco 878 de g.shdsl uzerinde voip e bandwidth ayirmak icin ve hattin 1 Mbit lik bandwidth ini tanımlamak için hangi komutlari eklemem gerekiyor,

ve ekteki kurtulus deponun konfigurasyonuna cisco1700 de voip için 128 k hat ayirmak için frame-relay da hangi komutları girmem gerekiyor.

cok sagolun.

framerelayqosconf

! ******************************************************************
! Cisco1760.cfg - Cisco router configuration file
! Automatically created by Cisco ConfigMaker v2.6 Build 6
! 18 Kasım 2006 Cumartesi, 03:17:47
!
! Hostname: Cisco1760
! Model: 1760
! ******************************************************************
!

service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!

hostname Cisco1760
!

enable password a
!

no ip name-server
!

ip subnet-zero
no ip domain-lookup
ip routing
!

interface FastEthernet 0/0
 no description
 no ip address
 shutdown
!

interface Serial 0/0
 no shutdown
 no description

 service-module t1 clock source line
 service-module t1 data-coding normal
 service-module t1 remote-loopback full
 service-module t1 framing esf
 service-module t1 linecode b8zs
 service-module t1 lbo none
 service-module t1 remote-alarm-enable

 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!

interface Serial 0/0.1 point-to-point
 no shutdown
 description connected to Internet
 ip address 212.54.55.56 255.255.255.0
 frame-relay interface-dlci 456
 frame-relay ip rtp header-compression
 ip rtp reserve 16384 100 256
 traffic-shape rate 2048000 256000 256000
!

interface Serial 1/0
 no description
 no ip address
 shutdown
!

interface Serial 1/1
 no description
 no ip address
 shutdown
!

router rip
 version 2
 passive-interface Serial 0/0.1
 no auto-summary
!
!

ip classless
!
! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Serial 0/0.1
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!

line console 0
 exec-timeout 0 0
 password a
 login
!

line vty 0 4
 password a
 login
!

end

qos command
http://www.cisco.com/application/pdf/en/us/guest/products/ps6350/c2001 /ccmigration_09186a00804916c8.pdf

rtp header compression
http://www.cisco.com/en/US/products/ps6350/products_configuration_guid e_chapter09186a00805f284e.html

tcp header compression
http://www.cisco.com/en/US/products/ps6350/products_configuration_guid e_chapter09186a00805f2850.html#wp1054356

class based
http://www.cisco.com/en/US/products/ps6350/products_configuration_guid e_chapter09186a00805f2852.html#wp1027258

sdm download link
http://www.cisco.com/pcgi-bin/tablebuild.pl/sdm

! ******************************************************************
! Cisco1760.cfg - Cisco router configuration file
! Automatically created by Cisco ConfigMaker v2.6 Build 6
! 18 Kasım 2006 Cumartesi, 04:34:49
!
! Hostname: Cisco1760
! Model: 1760
! ******************************************************************
!

service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!

hostname Cisco1760
!

enable password a
!

no ip name-server
!

ip subnet-zero
no ip domain-lookup
ip routing
!

interface FastEthernet 0/0
 no description
 no ip address
 shutdown
!

interface Serial 0/0
 no shutdown
 no description

 service-module t1 clock source line
 service-module t1 data-coding normal
 service-module t1 remote-loopback full
 service-module t1 framing esf
 service-module t1 linecode b8zs
 service-module t1 lbo none
 service-module t1 remote-alarm-enable

 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!

interface Serial 0/0.1 point-to-point
 no shutdown
 description connected to Internet
 ip address 212.54.55.56 255.255.255.0
 frame-relay interface-dlci 456
 frame-relay ip rtp header-compression
 ip rtp reserve 16384 100 256
 traffic-shape rate 2048000 256000 256000
 !
 ! Committed Access Rate (CAR)
 !

 rate-limit output access-group 100 512000 8000 8000 conform-action set-prec-continue 2 exceed-action drop
 rate-limit output access-group 101 64000 6000 6000 conform-action set-prec-continue 3 exceed-action drop
 rate-limit output access-group 102 32000 8000 8000 conform-action set-prec-continue 4 exceed-action drop
!
!

interface Serial 1/0
 no description
 no ip address
 shutdown
!

interface Serial 1/1
 no description
 no ip address
 shutdown
!
! Access Control List 100
!

no access-list 100
access-list 100 permit tcp any any eq www
!
! Access Control List 101
!

no access-list 101
access-list 101 permit tcp any any eq telnet
!
! Access Control List 102
!

no access-list 102
access-list 102 permit tcp any any range ftp-data ftp
!

router rip
 version 2
 passive-interface Serial 0/0.1
 no auto-summary
!
!

ip classless
!
! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Serial 0/0.1
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!

line console 0
 exec-timeout 0 0
 password a
 login
!

line vty 0 4
 password a
 login
!

end

kurtulusdepo

kurtulus_depo#sh ru
Building configuration...

Current configuration : 1543 bytes
!

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

hostname kurtulus_depo
!

boot-start-marker
boot-end-marker
!

enable secret 5 $1$axSQ$SCCg9kmDJXjpoqv3LqX3P/ enable password 7 03075A090A0A2F495A
!

no aaa new-model
ip subnet-zero
!
!
!
!

no ip domain lookup
ip domain name 192.168.1.1
ip cef
no scripting tcl init
no scripting tcl encdir
!
!
!
!

interface FastEthernet0
 description CONNECTIONS TO LOCAL LAN
 ip address 192.168.2.250 255.255.255.0
 speed auto
!

interface Serial0
 description Connection to 2048 Frame-Relay links  no ip address
 encapsulation frame-relay IETF
 load-interval 30
!

interface Serial0.1 point-to-point
 description Connection to G.SHDSL Link SairNigar  ip address 10.10.11.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 34
!

interface Serial0.2 point-to-point
 description Connection to G.SHDSL Link SamanYolu  ip address 10.10.12.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 33
!

interface Serial0.3 point-to-point
 description Connection to G.SHDSL Link Real  ip address 10.10.13.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 35
!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.11.2
ip route 192.168.3.0 255.255.255.0 10.10.12.2
ip route 192.168.4.0 255.255.255.0 10.10.13.2
no ip http server
!
!
!

control-plane
!

banner login ^C WelCome to Pijaluks Router ^C
!

line con 0
 password 7 094F4F0B150019171F
line aux 0
line vty 0 4
 password 7 1306161007090A2F3F
 login
!

no scheduler allocate
!

end

sairnigar

SairNigar#sh ru
Building configuration...

Current configuration : 3146 bytes
!

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

hostname SairNigar
!

boot-start-marker
boot-end-marker
!

logging buffered 51200 warnings
!

no aaa new-model
!

resource policy
!

ip subnet-zero
ip cef
!
!

no ip domain lookup
ip domain name 192.168.1.1
!
!

crypto pki trustpoint TP-self-signed-3745178049  enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3745178049  revocation-check none
 rsakeypair TP-self-signed-3745178049
!
!

crypto pki certificate chain TP-self-signed-3745178049  certificate self-signed 01
  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 0405   31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 4365   69666963 6174652D 33373435 31373830 3439301E 170D3032 30333031 3031   31345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 0313   4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 3734   37383034 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 8189   8100C7EE E060A8CB 517809A1 9E756FE3 37465090 49A645EC B6EA0DDE C60C   DC3DA06E 417C3E21 45F09770 61CDDF89 6FC8CA1C AC896A5B 37A8D86B 2D31   EEF383BD 4A9CF139 90CA6D0F 65FC0E8E 8326A859 A5EC3AC2 B6002AC7 2CEB   D554A8FC D5C4A904 27083E33 82FA3D11 B2D69F90 4C517B36 6D7E5D19 B9BA   D7410203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 3020   551D1104 19301782 15536169 724E6967 61722E31 39322E31 36382E31 2E31   0603551D 23041830 16801458 D4EBEEF5 73D47A68 23B010F0 885E0BE0 A130   1D060355 1D0E0416 041458D4 EBEEF573 D47A6823 B010F088 5E0BE0A1 30B1   06092A86 4886F70D 01010405 00038181 00A48E33 796FAF8E 6219060D 04EB   D1EF3DA2 DED4DC8B 3EC2889D FBAD285C DA0DF98B 3C0A8576 BAB1C0B0 0B4E   77E052F7 B31BEBEA 23DD25BF B28FCF8F 0CC667F4 3A697658 A1ADDD7A 57BF   7762623D 6DED6A1D EE00532C C9C7B2BB 488CA627 ADCD2F79 7FFDE4C5 80D5   F0801625 F848DB76 86FA61BC 274AE509 5F   quit
username cisco privilege 15 secret 5 $1$QhdP$x.4aGZ/REjQSxaR3FSkEh1
!
!

controller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zero
 dsl-mode shdsl symmetric annex B
 line-rate auto
!
!
!
!

interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!

interface ATM0
 ip address 10.10.11.2 255.255.255.0
 load-interval 90
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5snap
 !
!

interface FastEthernet0
!

interface FastEthernet1
!

interface FastEthernet2
!

interface FastEthernet3
!

interface Vlan1
 description connection to Local LAN
 ip address 192.168.1.250 255.255.255.0
 ip tcp adjust-mss 1452
!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.2.0 255.255.255.0 10.10.11.1
ip route 192.168.3.0 255.255.255.0 10.10.11.1
ip route 192.168.4.0 255.255.255.0 10.10.11.1

!

ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!

no cdp run
!

control-plane
!
!

line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!

scheduler max-task-time 5000
end Received on Sun Nov 19 20:01:09 2006

This archive was generated by hypermail 2.1.8 : Sun Nov 19 2006 - 20:01:24 EET