RE: [cisco-ttl] Cisco 2821 Pri Kart voip

From: Murat TAŞKIN <murat_at_....>
Date: Tue Oct 31 2006 - 10:10:39 EET


Merhaba
Erdem Bey bu komutu daha önceden denemistim ama olumlu bir sonuc alamadım.komutu girmeden ve girdikten sonra da debug cıktısında farklı bir sonuc yok.Bu konuyu anlatan bir dokuman var cisco'nun sitesinde.process indicator komutları var.aynı zamanda bunlarıda denedim ama yine maalesef olmadı. isdn q931 cıktısı asagıdaki gibidir.

*Oct 31 07:51:58.164: ISDN Se0/0/1:15 Q931: RX <- SETUP pd = 8 callref = 0x0060  Bearer Capability i = 0x8090A3
 Standard = CCITT
 Transer Capability = Speech
 Transfer Mode = Circuit
 Transfer Rate = 64 kbit/s
 Channel ID i = 0xA98387
 Exclusive, Channel 7
 Calling Party Number i = 0x0083, '8958'  Plan:Unknown, Type:Unknown
 High Layer Compat i = 0x9181
*Oct 31 07:51:58.172: ISDN Se0/0/1:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x 8060

        Channel ID i = 0xA98387
                Exclusive, Channel 7
        Progress Ind i = 0x8188 - In-band info or appropriate now available
*Oct 31 07:51:58.172: ISDN Se0/0/1:15 Q931: TX -> CONNECT pd = 8 callref = 0x80 60
*Oct 31 07:51:58.248: ISDN Se0/0/1:15 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x0060
*Oct 31 07:51:58.248: %ISDN-6-CONNECT: Interface Serial0/0/1:6 is now connected to 8958 N/A
*Oct 31 07:52:03.560: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 i s 0x0 0x0, Calling num 8958
*Oct 31 07:52:03.564: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 i s 0x0 0x0, Called num
*Oct 31 07:52:03.564: ISDN Se0/0/1:15 Q931: TX -> SETUP pd = 8 callref = 0x0052
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98381
                Exclusive, Channel 1
        Calling Party Number i = 0x0083, '8958'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80
                Plan:Unknown, Type:Unknown
        High Layer Compat i = 0x9181

*Oct 31 07:52:03.620: ISDN Se0/0/1:15 Q931: RX <- SETUP_ACK pd = 8 callref = 0x 8052
        Channel ID i = 0xA98381
                Exclusive, Channel 1

*Oct 31 07:52:04.304: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/ 1:6, changed state to up
*Oct 31 07:52:18.628: ISDN Se0/0/1:15 Q931: RX <- ALERTING pd = 8 callref = 0x8 052
*Oct 31 07:52:22.756: ISDN Se0/0/1:15 Q931: RX <- CONNECT pd = 8 callref = 0x80 52
        Connected Number i = 0x0080, '6999'
        Connected SubAddr i = 0x8082, '699', 0xB9
*Oct 31 07:52:22.756: %ISDN-6-CONNECT: Interface Serial0/0/1:0 is now connected to N/A
*Oct 31 07:52:22.760: ISDN Se0/0/1:15 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x0052
*Oct 31 07:52:33.688: ISDN Se0/0/1:15 Q931: RX <- DISCONNECT pd = 8 callref = 0 x8052

        Cause i = 0x8090 - Normal call clearing *Oct 31 07:52:33.692: %ISDN-6-DISCONNECT: Interface Serial0/0/1:0 disconnected from unknown , call lasted 10 seconds
*Oct 31 07:52:33.692: ISDN Se0/0/1:15 Q931: TX -> RELEASE pd = 8 callref = 0x00 52
*Oct 31 07:52:33.696: %ISDN-6-DISCONNECT: Interface Serial0/0/1:6 disconnected from 8958 , call lasted 35 seconds
*Oct 31 07:52:33.696: ISDN Se0/0/1:15 Q931: TX -> DISCONNECT pd = 8 callref = 0 x8060

        Cause i = 0x8090 - Normal call clearing *Oct 31 07:52:33.764: ISDN Se0/0/1:15 Q931: RX <- RELEASE_COMP pd = 8 callref =  0x8052

        Cause i = 0x8090 - Normal call clearing *Oct 31 07:52:33.804: ISDN Se0/0/1:15 Q931: RX <- RELEASE pd = 8 callref = 0x00 60

        Cause i = 0x8090 - Normal call clearing *Oct 31 07:52:33.804: ISDN Se0/0/1:15 Q931: TX -> RELEASE_COMP pd = 8 callref =  0x8060

-----Original Message-----
From: cisco-ttl@yahoogroups.com [mailto:cisco-ttl@yahoogroups.com] On Behalf Of Erdem Haseki (Koç.net) Sent: Monday, October 30, 2006 12:31 PM
To: cisco-ttl@yahoogroups.com
Subject: RE: [cisco-ttl] Cisco 2821 Pri Kart voip

Merhaba,

Global config'te

!

voice rtp send-recv
!

Yazıp tekrar dener misiniz? Birde denemenizin "debug isdn q931" çıktısını da gönderebilir misiniz?

İyi çalışmalar.
Erdem Haseki

-----Original Message-----
From: cisco-ttl@yahoogroups.com [mailto:cisco-ttl@yahoogroups.com] On Behalf Of Murat TAŞKIN Sent: Monday, October 30, 2006 11:14 AM
To: cisco-ttl@yahoogroups.com
Subject: [cisco-ttl] Cisco 2821 Pri Kart voip

Merhabalar,
Merkez lokasyonda Cisco 2821 router a takılı Pri kart ile santral arasında voip için bir baglantım var.Ortamda birde call manager server bulunmakta.Voip için H.323 kullanmaktayim.Bölgelerden merkeze dogru gelen aramalarda,(merkezdeki santral de otomatik robot olmasina ragmen) robot devreye girmemekte ve arayan aboneye çalma sesi gitmemektedir.2821 konfigurasyonu asagidaki gibidir.Bu sorun santralden mi yoksa router konfigurasyonundanmi kaynaklidir?Bilen arkadaslarin cevaplarini bekliyorum.(Cisco nun site dında bir takım dokumanlar buldum.Ring Back ile ilgili ama bu soruna çözüm olmadı.)

Tesekürler.

router#sh run
Building configuration...

Current configuration : 2484 bytes
!

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

hostname router
!

boot-start-marker
boot-end-marker
!

logging buffered 51200 warnings
no logging console
!

network-clock-participate wic 0
no aaa new-model
ip subnet-zero
!
!

ip cef
!
!

isdn switch-type primary-net5
!

voice-card 0
!

controller E1 0/0/0
 pri-group timeslots 1-31
!

controller E1 0/0/1
 pri-group timeslots 1-31
!

interface GigabitEthernet0/0
 description Local Area Network
 ip address 192.168.10.2
 no ip mroute-cache
 duplex auto
 speed auto
 h323-gateway voip bind srcaddr 192.168.10.2 ! interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!

interface Serial0/0/0:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn bchan-number-order ascending
 no cdp enable
!

interface Serial0/0/1:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn send-alerting
 isdn bchan-number-order ascending
 no cdp enable
!

ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!

control-plane
!

voice-port 0/0/0:15
 cptone TR
 timeouts interdigit 3
!

voice-port 0/0/1:15
 cptone TR
 timeouts interdigit 3

dial-peer voice 1 pots
 destination-pattern 800T
 port 0/0/0:15
!

dial-peer voice 2 pots
 destination-pattern 800T
 port 0/0/1:15
!

dial-peer voice 3 voip
 destination-pattern 2T
 session target ipv4:192.168.10.10

gateway

line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!

scheduler allocate 20000 1000
!

end

router#

Murat TASKIN

--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links







--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links







--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/cisco-ttl/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/cisco-ttl/join
    (Yahoo! ID required)

<*> To change settings via email:
    mailto:cisco-ttl-digest@yahoogroups.com 
    mailto:cisco-ttl-fullfeatured@yahoogroups.com

<*> To unsubscribe from this group, send an email to:
    cisco-ttl-unsubscribe@yahoogroups.com

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 
Received on Tue Oct 31 15:12:25 2006

This archive was generated by hypermail 2.1.8 : Tue Oct 31 2006 - 15:12:25 EET