RE: [cisco-ttl] NAT arkasındaki makinelere erişmek

From: Özcan <ozcanilikhan_at_....>
Date: Wed Nov 16 2005 - 17:32:42 EET


Öncelikle yardımınız için teşekkürler,    

  Verdiğiniz komutun <iç-ip> <iç-port> kısmına kadar sorun yok, yalnız dış port kısmını nasıl dinamik yapaliriz? Demek istediğim şu ki dışarıdaki herhangi bir kullanıcı içerideki FTP sunucusuna bağlanmak istediğinde, istemcinin OS u otomatik olarak boş bir portu kullanacaktır ve biz bunun ne olduğunu bilemeyiz, ikincisi dışarıdaki birden çok IP ye veyahut herkese NAT arkasındaki FTP sunucuya erişim vermek istersek nasıl bir komut uygulayabiliriz?    

  örneğin
- Yönlendiriciye sadece 80.90.100.0/24 ağından gelen FTP isteklerini 192.168.1.254 ip li makineye yönlendir.

  ben denemek amacıyla
  ip nat inside source static tcp 192.168.1.250 80 any any    

  gibi bir komut girdiğimde "any" ifadelerinden dolayı hata verdi.   

Cumhur / Yahoo <yahoo@cumhur.com> wrote:   Selamlar,

ip nat inside source static tcp (xxx.xxx.xxx.xxx)ic-ip yyy(ic-port) (aaa.aaa.aaa.aaa)dis-ip zzz(dis-port)

ornek ftp:

ip nat inside source static tcp 192.168.50.2 21 212.156.4.4 2121

Kolay gelsin.
Cumhur

-----Original Message-----
From: cisco-ttl@yahoogroups.com [mailto:cisco-ttl@yahoogroups.com] On Behalf Of Özcan YLYKHAN
Sent: Tuesday, November 08, 2005 23:22
To: Cisco-TTL
Subject: [cisco-ttl] NAT arkasındaki makinelere erişmek

Merhaba ,

Ekteki resimde şekillendirmeye çalıştığım gibi bir ağımız olduğunu var sayalım, içeride private IP kullanılmış ve routerda NAT aktif. Ben iki tane sunucu kurmak istiyorum, biri sadece FTP sunucu olarak kullanılacak, diğeri hem WEB sunucu hemde oyun sunucusu olarak kullanılacak, oyun sunucusuna bağlanmak için gerekli port numaraları 27005, 27015, 27025.

Bu ağın dışındaki her hangi bir istemcinin içerideki sunuculara (örneğin FTP sunucusuna) erişmesi için ne tür bir konfigürasyona ihtiyacımız var. Mesela cihaza bir adet DSL kart takılmış olsun ve mevcut konfigürasyondan kesitler aşağıdaki gibi olsun. (ADSL hattı üzerinden dışa erişim vermek -performans açısından- mantıklı değil ama bazen iş yerindeki bilgisayarlara çeşitli nedenlerden dolayı dışarından erişmek gerekebiliyor.).

Böyle birşey mümkünmü? Mümkünse konfigürasyonda ne gibi bir değişiklik yapmamız gerekiyor?

interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
....
interface FastEthernet0
description +++ LAN +++
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
.....
interface Dialer0
description +++ TTNet ADSL +++
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
......
ip nat inside source list 1 interface Dialer0 overload ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
......
access-list 1 permit 192.168.1.0 0.0.0.255 dialer-list 1 protocol ip permit             



Yahoo! FareChase - Search multiple travel sites in one click.

[Non-text portions of this message have been removed]

--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links









--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 



  SPONSORED LINKS 
        Communication and networking   Cisco systems inc   Wireless communication and networking 
    
---------------------------------
  YAHOO! GROUPS LINKS 

    
    Visit your group "cisco-ttl" on the web.
    
    To unsubscribe from this group, send an email to:
 cisco-ttl-unsubscribe@yahoogroups.com
    
    Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service. 

    
---------------------------------
  

  


		
---------------------------------
 Yahoo! FareChase - Search multiple travel sites in one click.  

[Non-text portions of this message have been removed]





------------------------ Yahoo! Groups Sponsor --------------------~--> 
Get fast access to your favorite Yahoo! Groups. Make Yahoo! your home page
http://us.click.yahoo.com/dpRU5A/wUILAA/yQLSAA/26EolB/TM
--------------------------------------------------------------------~-> 

--
Cisco Teknik Tartisma Listesi (Cisco-ttl)

Bu listede onerilen degisikliklerin uygulanmasindaki tum sorumluluk 
kullaniciya aittir. Liste yoneticileri, oneride bulunan liste uyeleri ya da 
bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar. 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/cisco-ttl/

<*> To unsubscribe from this group, send an email to:
    cisco-ttl-unsubscribe@yahoogroups.com

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 
Received on Wed Nov 16 17:45:15 2005

This archive was generated by hypermail 2.1.8 : Wed Nov 16 2005 - 17:45:15 EET