Re: [cisco-ttl] Cisco1721+wic1adsl

From: Ilker Temir (ilker_at_ilkertemir.com)
Date: Sat Mar 12 2005 - 23:20:38 EET


Asagidaki konfigurasyonda per-packet load-sharing ayari yapmissiniz
ancak bu CEF olmadan calismaz. Fast-switching ile dogrudan
destination-based switching yaparsiniz bu da tum trafigin ayni hattan
cikip, dolayisiyla oradan NATlanmasina girmesine yol acar. Oncelikle 'ip
cef' ile CEF'i aktive etmeyi deneyin. Kullandiginiz versiyona bagli
olarak bu platformda CEF ile sorun yasama olasiliginiz var.

Bana ozel gonderdiginiz mesaja istinaden, onerdigim konfigurasyonu dogru
uygulamamissiniz. route-map icinde next-hop tanimlayan satirlar yok.
Bunlar bulunmadan policy based routing uygulamanin bir anlami yok. Bunu
duzelttikten sonra hizla ilgili bir problem yasarsaniz tum cikis
interfaceleri uzerinde 'ip policy route-cache' tanimlayin, ya da CEF'i
aktive edin.

Iki yontem arasindaki fark birinde hangi bilgisayarlarin hangi hatti
kullanacagini belirleyebilirsiniz digerinde belirleyemezsiniz.

Ilker

Özcan İLİKHAN wrote:
>
> Merhaba;
> Konfigürasyonu dediğiniz gibi değiştirdim, şimdi ATM1 üzeriden bağlantı gerçekleşiyor. Yalnız anladığım kadarıyla benim konfigürasyonda"ip nat inside source list ...." ve access list lerde hata var çünkü aynı anda iki hat çalışmıyor. Hat ve kartlar sağlam, tek tek deneyince sorun yok. Ama şu yük dengeleme (load-balanacin/sharing) işini bir türlü beceremedim. yardım edebilirseniz memnun olurum. İlker TEMİR (grubun yöneticisi) bana ayrı bir yöntem önerdi, onu uyguladım fakat çok yavaş şekilde çalıştı. O konfigürasyonu daha sonra yollarım.
>
> !
> hostname Anka1_1721
> !
> enable password *******
> !
> ip subnet-zero
> ip name-server 212.156.4.4
> ip name-server 212.156.4.1
> !
> interface ATM1
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> dsl operating-mode auto
> no fair-queue
> ip load-sharing per-packet
> !
> interface ATM1.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 1
> !
> !
> interface ATM0
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> dsl operating-mode auto
> no fair-queue
> ip load-sharing per-packet
> !
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 2
> !
> !
> interface FastEthernet0
> description +++ LAN +++
> ip address 10.0.0.130 255.255.255.0
> ip nat inside
> ip tcp adjust-mss 1452
> speed 100
> hold-queue 100 out
> ip nat inside
> half-duplex
> !
> !
> interface Dialer1
> description +++ TTNet ADSL via ATM1 +++
> ip address negotiated
> ip mtu 1492
> ip nat outside
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> no cdp enable
> ppp authentication pap callin
> ppp pap sent-username ****@ttnet password *******
> !
> !
> interface Dialer0
> description +++ TTNet ADSL via ATM0 +++
> ip address negotiated
> ip mtu 1492
> ip nat outside
> encapsulation ppp
> dialer pool 2
> dialer-group 2
> no cdp enable
> ppp authentication pap callin
> ppp pap sent-username *******@ttnet password *******
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> ip route 0.0.0.0 0.0.0.0 Dialer0
> ip route 10.0.0.0 255.255.255.0 FastEthernet0
> !
> ip http server
> no ip http secure-server
> !
> ip nat inside source list 101 interface Dialer0 overload
> ip nat inside source list 101 interface Dialer1 overload
> ip nat inside source static 10.0.0.100 10.0.1.100
> !
> access-list 1 permit 10.0.0.0 0.0.0.255
> access-list 101 permit ip 10.0.0.0 0.0.0.255 any
> dialer-list 1 protocol ip permit
> dialer-list 2 protocol ip permit
> !
> line vty 0 4
> password *******
> login
> !
> !
>
> Emre SÜMENGEN <esumengen_at_unibel.com.tr> wrote:
>
> Merhabalar,
> Ben mi yanlis goruyorum, yoksa asagidaki satirlardan iki adet mi var konfigurasyonunuzda?
>
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 2
> !
>
> Interface ATM1'den sonrakini, "interface ATM1.1 point-to-point" seklinde degistirmeniz gerekmez mi?
>
> Ayrica, load-balancing icin (per-packet) de her ATM interface'i icine "ip load-sharing per-packet" satiri girmelisiniz.
> Bu sekilde paketler sirasiyla 0. ve 1. interface'lere route edilecektir (daha dogrusu nat edilecektir)...
>
> Eger problem devam ederse, router'in loglarini gonderebilir yada ADSL telefonlari degistirerek deneyebilirsiniz. Biliyorsunuz, Turkiye'de halen ADSL tam olarak oturamadi ne yazik ki...
>
> Emre Sümengen
> Sistem Yöneticisi
> İzmir Büyükşehir Belediyesi
> Ünibel Özel Eğitim ve Bilgi Teknolojileri San. ve Tic. A.Ş.
> esumengen_at_unibel.com.tr
>
>
> -----Original Message-----
> From: ozcanilikhan [mailto:ozcanilikhan_at_yahoo.com]
> Sent: Saturday, March 05, 2005 12:38 PM
> To: cisco-ttl_at_yahoogroups.com
> Subject: [cisco-ttl] Cisco1721+wic1adsl
>
>
>
>
> Merhaba;
> Cisco 1721 ve iki adet wic1-adsl kart ile baðlantý yapmaya
> çalýþýyorum. Ýki hattýn içeriye dengeli bir biçimde
> (load balancing)
> daðýtýlmasýný istiyorum, tek hat üzerinden
> baðlantýyý kurdum,
> konfigürasyonu deðiþtirip çift hatta uyarlamaya
> çalýþtým, fakat bir
> yerlerde hata yapmýþ olmalýyým ki baðlantý
> gerçekleþmedi. Yardým
> edebilirseniz memnun olurum.
> --------------------------------
> !
> hostname Anka1_1721
> !
> enable password ********
> !
> ip subnet-zero
> ip name-server 212.156.4.4
> ip name-server 212.156.4.1
> !
> interface ATM0
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> dsl operating-mode auto
> no fair-queue
> !
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 1
> !
> !
> interface ATM1
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> dsl operating-mode auto
> no fair-queue
> !
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 2
> !
> !
> interface FastEthernet0
> description +++ LAN +++
> ip address 10.0.0.130 255.255.255.0
> ip nat inside
> ip tcp adjust-mss 1452
> speed 100
> hold-queue 100 out
> half-duplex
> !
> !
> interface Dialer0
> description +++ TTNet ADSL +++
> ip address negotiated
> ip mtu 1492
> ip nat outside
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> no cdp enable
> ppp authentication pap callin
> ppp pap sent-username *****@ttnett password ******
> !
> !
> interface Dialer1
> description +++ TTNet ADSL +++
> ip address negotiated
> ip mtu 1492
> ip nat outside
> encapsulation ppp
> dialer pool 2
> dialer-group 2
> no cdp enable
> ppp authentication pap callin
> ppp pap sent-username ******@ttnet password ******
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> ip route 0.0.0.0 0.0.0.0 Dialer1
> ip route 10.0.0.0 255.255.255.0 FastEthernet0
> !
> ip http server
> no ip http secure-server
> !
> ip nat inside source list 101 interface Dialer0 overload
> ip nat inside source list 101 interface Dialer1 overload
> ip nat inside source static 10.0.0.100 10.0.1.100
> !
> access-list 1 permit 10.0.0.0 0.0.0.255
> access-list 101 permit ip 10.0.0.0 0.0.0.255 any
> dialer-list 1 protocol ip permit
> dialer-list 2 protocol ip permit
> !
> !
> ----------------------------------
> Bu tek hat için hazýrladýðým konfigürasyon, sorunsuz
> çalýþýyor.
> !
> hostname Anka1_1721
> !
> enable password *********
> !
> ip subnet-zero
> ip name-server 212.156.4.4
> ip name-server 212.156.4.1
> !
> interface ATM0
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> dsl operating-mode auto
> no fair-queue
> !
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 1
> !
> !
> interface FastEthernet0
> description +++ LAN +++
> ip address 10.0.0.130 255.255.255.0
> ip nat inside
> ip tcp adjust-mss 1452
> speed 100
> hold-queue 100 out
> half-duplex
> !
> !
> interface Dialer0
> description +++ TTNet ADSL +++
> ip address negotiated
> ip mtu 1492
> ip nat outside
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> no cdp enable
> ppp authentication pap callin
> ppp pap sent-username ******@ttnet password ******
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> ip route 10.0.0.0 255.255.255.0 FastEthernet0
> !
> ip http server
> no ip http secure-server
> !
> ip nat inside source list 101 interface Dialer0 overload
> ip nat inside source static 10.0.0.100 10.0.1.100
> !
> access-list 1 permit 10.0.0.0 0.0.0.255
> access-list 101 permit ip 10.0.0.0 0.0.0.255 any
> dialer-list 1 protocol ip permit
> !
> !
>
>
>
>
>
>
>
>
> --
>
> Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.
>
> Listede onerilen cozumlerin uygulanmasindaki tum sorumluluk kullaniciya aittir. Liste yoneticileri, liste uyeleri ya da bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
>
> Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.
> Yahoo! Groups Links
>
>
>
>
>
>
>
>
>
> --
>
> Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.
>
> Listede onerilen cozumlerin uygulanmasindaki tum sorumluluk kullaniciya aittir. Liste yoneticileri, liste uyeleri ya da bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
>
> Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.
>
>
> Yahoo! Groups SponsorADVERTISEMENT
>
>
> ---------------------------------
> Yahoo! Groups Links
>
> To visit your group on the web, go to:
> http://groups.yahoo.com/group/cisco-ttl/
>
> To unsubscribe from this group, send an email to:
> cisco-ttl-unsubscribe_at_yahoogroups.com
>
> Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
>
>
>
> ---------------------------------
> Do you Yahoo!?
> Make Yahoo! your home page
>
> [Non-text portions of this message have been removed]
>
>
>
>
>
>
> --
>
> Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.
>
> Listede onerilen cozumlerin uygulanmasindaki tum sorumluluk kullaniciya aittir. Liste yoneticileri, liste uyeleri ya da bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.
>
> Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.
> Yahoo! Groups Links
>
>
>
>
>

--

Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.

Listede onerilen cozumlerin uygulanmasindaki tum sorumluluk kullaniciya aittir. Liste yoneticileri, liste uyeleri ya da bu uyelerin calistigi kuruluslar herhangi bir sekilde sorumlu tutulamazlar.

Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz. Yahoo! Groups Links

<*> To visit your group on the web, go to: http://groups.yahoo.com/group/cisco-ttl/

<*> To unsubscribe from this group, send an email to: cisco-ttl-unsubscribe_at_yahoogroups.com

<*> Your use of Yahoo! Groups is subject to: http://docs.yahoo.com/info/terms/



This archive was generated by hypermail 2.1.3 : Sat Mar 12 2005 - 23:21:13 EET