RE: [cisco-ttl] frame-relay de ses problemi

From: Ali KAPTAN (ali.kaptan_at_alikaptan.name.tr)
Date: Mon Feb 07 2005 - 15:14:56 GMT

  • Next message: Ozgur Erdogan: "[cisco-ttl] leased line"

    Ekteki configürasyonu kullanabilirsiniz. Başarılı bir şekilde çalışıyor.

    voice call carrier capacity active
    !
    !
    !
    !
    !
    !
    !
    !
    !
    mta receive maximum-recipients 0
    !
    !
    !
    interface FastEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     no keepalive
     speed auto
    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     no fair-queue
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     bandwidth 256
     ip address 20.20.20.1 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     frame-relay class voip
     frame-relay interface-dlci 102
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 20.20.20.2
    no ip http server
    !
    !
    !
    map-class frame-relay voip
     frame-relay cir 256000
     frame-relay bc 2560
     frame-relay be 0
     frame-relay mincir 256000
     service-policy output qos
    access-list 101 permit udp any any range 16384 32768
    !
    call rsvp-sync
    !
    voice-port 1/0
     cptone TR
    !
    voice-port 1/1
     cptone TR
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 1 pots
     destination-pattern 232
     port 1/0
    !
    dial-peer voice 2 pots
     destination-pattern 232
     port 1/1
    !
    dial-peer voice 3 voip
     destination-pattern 242
     session target ipv4:20.20.20.2
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !
    dial-peer voice 4 voip
     destination-pattern 242
     session target ipv4:20.20.20.2
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !

    -----Original Message-----
    From: Arda Balkanay [mailto:wolverard_at_yahoo.com]
    Sent: Sunday, February 06, 2005 1:48 AM
    To: cisco-ttl_at_yahoogroups.com
    Subject: Re: [cisco-ttl] frame-relay de ses problemi

    merhaba
    ses kayiplarini azaltmak veya onlemek icin QoS
    yapmalisin. QoS'u uygulamadan once de ses paketlerini
    routerina tanitmalisin. Bunu asagidaki yollarla
    yapabilirsin
    1) ses paketleri udp 16384 32767 port araligini
    kullanir
    2) ses paketlerinde dscp, ef olarak isaretlidir
    bunlari acller ile kolayca yazabilirsin:
    access-list 155 permit udp any any range 16384 32767
    veya
    access-list 155 permit udp any any dscp ef

    ilgili accesslistleri de s}n}f tan}mlarinda
    kullanabilirsin. Bunu da class-map kullanarak yaparsin
    class-map voice
    match access-group 155

    veya hic acller ile ugrasmayip
    class-map voice
    match ip rtp 16384 16383 //16384'ten baslayacak ve
    sonraki 16383 portu kapsayacak

    veya
    class-map voice
    match ip dscp ef

    daha sonra ses paketlerini isaretlemeyi bitirdikten
    sonra voip icin onemli olan sinyallesme paketleri
    tanitilmalidir.h323 sinyallesme icin tcp 1720g portu
    kullanir. bunun icinde bi acl yazilabilir
    access-list 154 permit tcp any eq 1720 any
    access-list 154 permit tcp any any eq 1720

    gene yukarida oldugu gibi

    class-map sinyallesme
    match access-group 154

    butun bu islemlerden sonra (ses trafigi ve
    sinyallesme) policy olusturmalisin
    bunun icin tikaniklik aninda ses paketlerine verecegin
    priority veya ayiracagin onceligi
    iyi ayarlaman gerekir. Mesela

    policy-map mypolicy
      class voice-traffic
      priority 45
      class voice-signaling
      bandwidth 8
      class class-default //class-mapler ile
    belirtmedigin default trafik
      fair-queue

    daha sonra interface altinda output yonunde bu
    policini uygulamalisin
    service-policy output mypolicy

    Ayrica ses paketleri icin kabul edilebilir bir delay
    suresi vardir. Bu surenin asilmasi
    da ses kayiplarina neden olabilir. dusuk hizli
    hatlarda ozellikle seri interfaceler altinda
    serialization gecikmeleri yasanabilir. Bu gecikmelerin
    onune gecmek icin fragmentation yapilmalidir.
    Cisco.com'da bununla ilgili daha ayrintili dokumanlar
    mevcut ancak 128k'lik bir hat icin (sein her
    interfacin 128k oldugu icin) fragmentation boyutu 160
    byte'dir.
    bunu da
    frame-relay fragment 160
    komutu ile yapabilirsin ancak bunu yapmadan once biraz
    dokuman karistirmani oneririm cunku
    bunu ben hic denemedim.

    iyi calismalar
    Arda Balkanay

    --- Endercan Bulut <endercanb_at_binsal.com> wrote:

    >
    >
    > Merhabalar,
    >
    >
    >
    > Cisco 1600 router |zerine gift 128k frame relay hat
    > bapl}(Telekom hat
    > h}z}m}z} 256k ya g}karamad}p} igin 2 adet 128k
    > ald}k)
    >
    > Ses ve data ta~}nmas}n} ayr} ayr} hatlar |zerinden
    > yapmak istiyorum.^ubedeki
    > routerda ip route tan}m}yla pakaetleri iki hat
    > |zerinden gvndermeye gal}~t}m
    > bu performans} artt}rd} ama seste kesintiler
    > olu~turdu sesteki kesintileri
    > ortadan kald}rmak igin acaba daha neler yapabilirim.
    >
    >
    >
    > Ses cihaz} olarak Multitech cihazlar} kullan}yorum.
    >
    >
    >
    > Herkese Kolay Gelsin.
    >
    >
    >
    > Merkez router;
    >
    >
    >
    > interface Serial0.2 point-to-point
    >
    > description IST_LULEBURGAZ_1HAT_128K
    >
    > ip address 192.168.3.1 255.255.255.0
    >
    > no ip directed-broadcast
    >
    > no cdp enable
    >
    > frame-relay interface-dlci 18
    >
    >
    >
    > interface Serial0.6 point-to-point
    >
    > description IST_LULEBURGAZ_2HAT_128K
    >
    > bandwidth 128
    >
    > ip address 192.168.6.1 255.255.255.0
    >
    > no ip directed-broadcast
    >
    > no cdp enable
    >
    > frame-relay interface-dlci 20
    >
    >
    >
    > ip route 10.3.1.0 255.255.255.0 192.168.3.2
    >
    > ip route 10.3.1.0 255.255.255.0 192.168.6.2
    >
    >
    >
    > Subedeki Router
    >
    >
    >
    > interface Ethernet0
    >
    > ip address 10.3.1.1 255.255.255.0
    >
    >
    >
    > interface Serial0
    >
    > no ip address
    >
    > encapsulation frame-relay
    >
    > frame-relay lmi-type ansi
    >
    > !
    >
    > interface Serial0.1 point-to-point
    >
    > description FR_LULEBURGAZ_1HAT_128K
    >
    > ip address 192.168.3.2 255.255.255.0
    >
    > frame-relay interface-dlci 16
    >
    > !
    >
    > interface Serial1
    >
    > no ip address
    >
    > encapsulation frame-relay
    >
    > frame-relay lmi-type ansi
    >
    > !
    >
    > interface Serial1.1 point-to-point
    >
    > description FR_LULEBURGAZ_2HAT_128K
    >
    > ip address 192.168.6.2 255.255.255.0
    >
    > frame-relay interface-dlci 16
    >
    >
    >
    > ip route 0.0.0.0 0.0.0.0 192.168.3.1
    >
    > ip route 0.0.0.0 0.0.0.0 192.168.6.1
    >
    > !
    >
    >
    >
    > [Non-text portions of this message have been
    > removed]
    >
    >
    >
    >
    >
    >
    > Bu listenin Cisco Systems ile herhangi bir
    > baglantisi bulunmamaktadir.
    >
    > Listeden cikmak igin
    > cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir
    > e-posta gvnderebilirsiniz.
    > Yahoo! Groups Links
    >
    >
    > cisco-ttl-unsubscribe_at_yahoogroups.com
    >
    >
    >
    >
    >
    >

                    
    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com
     

    Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak igin cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir
    e-posta gvnderebilirsiniz.
    Yahoo! Groups Links

     

    Bu listenin Cisco Systems ile herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.
    Yahoo! Groups Links

    <*> To visit your group on the web, go to:
        http://groups.yahoo.com/group/cisco-ttl/

    <*> To unsubscribe from this group, send an email to:
        cisco-ttl-unsubscribe_at_yahoogroups.com

    <*> Your use of Yahoo! Groups is subject to:
        http://docs.yahoo.com/info/terms/
     



    This archive was generated by hypermail 2.1.5 : Mon Feb 07 2005 - 19:15:43 GMT