[cisco-ttl] VOIP ve yankı problemi

From: Vahit Ünal (vahit_at_ufotek.com)
Date: Fri Nov 28 2003 - 07:25:16 GMT

  • Next message: Levent Irkilmez: "Re: [cisco-ttl] VoIP"

    Merhabalar
    İstanbul ve Ankara arası VOIP kullanıyoruz. Eski çalışanlar tarafından bu konfigürasyonlar yapılmış. Herşey çok güzel, ama çok ciddi bir yankı problemimiz var. Hattımız 128K frame-relay ve kullanımı çok fazla değil.

    VOIP hakkında fazla bir bilgim yok, biraz araştırdım ama işin içinden çıkamadım. Aşağıda iki router'ın konfigürasyonları bulunuyor.

    Tavsiyelerinizi rica ediyorum.

    İyi çalışmalar...

    İSTANBUL AYARLARI

    Cisco 2620

    Merkez2620#sh run

    Building configuration...

     

    Current configuration:

    !

    version 12.1

    service timestamps debug uptime

    service timestamps log uptime

    service password-encryption

    !

    hostname Merkez2620

    !

    memory-size iomem 12

    ip subnet-zero

    no ip domain-lookup

    !

    voice-port 1/0/0

     input gain -6

     cptone TR

     timeouts call-disconnect 0

     description FXS

    !

    voice-port 1/0/1

     input gain -6

     cptone TR

     timeouts call-disconnect 0

     description FXS

    !

    voice-port 1/1/0

     input gain -6

     cptone TR

     timeouts call-disconnect 0

     description FXO

    !

    voice-port 1/1/1

     input gain -6

     cptone TR

     timeouts call-disconnect 0

     description FXO

    !

    !

    dial-peer voice 1 pots

     preference 1

     destination-pattern 10

     port 1/0/0

    !

    dial-peer voice 2 pots

     preference 2

     destination-pattern 10

     port 1/0/1

    !

    dial-peer voice 3 pots

     destination-pattern 12

     port 1/1/0

    !

    dial-peer voice 4 pots

     destination-pattern 12

     port 1/1/1

    !

    dial-peer voice 200 voip

     destination-pattern 30

     session target ipv4:10.0.0.6

     dtmf-relay cisco-rtp

     ip precedence 5

    !

     

    interface FastEthernet0/0

     ip address 192.168.0.2 255.255.255.0

     duplex auto

     speed auto

     no cdp enable

    !

    interface Serial0/0

     no ip address

     encapsulation frame-relay IETF

     no ip mroute-cache

     frame-relay traffic-shaping

     frame-relay lmi-type ansi

    !

    interface Serial0/0.3 point-to-point

     description Ankara Frame Relay CIR 128K

     bandwidth 128

     ip address 10.0.0.5 255.255.255.252

     no ip mroute-cache

     no cdp enable

     frame-relay interface-dlci 103 CISCO

      class voip128

     frame-relay ip rtp header-compression

     frame-relay payload-compression packet-by-packet

    !

    interface Dialer0

     no ip address

     no cdp enable

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 192.168.0.1

    ip route 192.168.3.0 255.255.255.0 10.0.0.6

    no ip http server

    !

    !

    map-class frame-relay voip128

     no frame-relay adaptive-shaping

     frame-relay cir 128000

     frame-relay bc 1280

     frame-relay be 0

     frame-relay mincir 128000

     frame-relay fair-queue

     frame-relay fragment 160

     frame-relay ip rtp priority 16384 16383 48

    !

    no cdp run

    snmp-server engineID local 0000000902000002B950B880

    snmp-server community private RO 1

    !

    line con 0

     transport input none

    line aux 0

    line vty 0 4

     

    login

    !

    no scheduler allocate

    end

    ANKARA AYARLARI
    Cisco 1750
    Current configuration:

    !

    version 12.1

    service timestamps debug uptime

    service timestamps log uptime

    service password-encryption

    !

    hostname Ankara1750

    !

    memory-size iomem 25

    ip subnet-zero

    no ip domain-lookup

    !

    !

    !

    interface Serial0

     no ip address

     encapsulation frame-relay IETF

     no ip mroute-cache

     frame-relay traffic-shaping

     frame-relay lmi-type ansi

    !

    interface Serial0.1 point-to-point

     description Frame Relay CIR 128

     bandwidth 128

     ip address 10.0.0.6 255.255.255.252

     no ip mroute-cache

     frame-relay interface-dlci 103 CISCO

      class voip128

     frame-relay ip rtp header-compression

     frame-relay payload-compression packet-by-packet

    !

    interface FastEthernet0

     --More--

    interface FastEthernet0

     ip address 192.168.3.1 255.255.255.0

     speed auto

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 10.0.0.5

    no ip http server

    !

    !

    map-class frame-relay voip128

     frame-relay cir 128000

     frame-relay bc 1280

     frame-relay be 0

     frame-relay mincir 128000

     no frame-relay adaptive-shaping

     frame-relay fair-queue

     frame-relay fragment 160

     frame-relay ip rtp priority 16384 16383 48

    !

    voice-port 2/0

     input gain -6

     cptone TR

     timing percentbreak 60

     description FXO

    description FXO

    !

    voice-port 2/1

     input gain -6

     cptone TR

     timing percentbreak 60

     description FXO

    !

    dial-peer voice 1 pots

     destination-pattern 30

     port 2/0

    !

    dial-peer voice 2 pots

     destination-pattern 30

     port 2/1

    !

    dial-peer voice 400 voip

     destination-pattern 4.

     session target ipv4:10.0.0.10

     ip precedence 5

    !

    dial-peer voice 100 voip

     destination-pattern 1.

     session target ipv4:10.0.0.5

     ip precedence 5

    !

    !

    line con 0

     transport input none

    line aux 0

    line vty 0 4

     login

    !

    no scheduler allocate

    end

     



    This archive was generated by hypermail 2.1.5 : Fri Nov 28 2003 - 11:26:49 GMT