RE: [cisco-ttl] qos problemi ( son hali )

From: gurkang_at_koc.net
Date: Mon Nov 03 2003 - 12:29:28 GMT

  • Next message: Genco Yilmaz: "[cisco-ttl] loading mesajlari"

    servis policy'leri interface altından kaldırıp map-class'a eklemeyi denediniz mi?
    iyi çalışmalar,

    -----Original Message-----
    From: Ali KAPTAN [mailto:ali.kaptan_at_asay.com.tr]
    Sent: Saturday, November 01, 2003 4:49 PM
    To: cisco-ttl_at_yahoogroups.com
    Subject: RE: [cisco-ttl] qos problemi ( son hali )

    bu konfigürasyonda hangi taraftan büyük dosya gönderirilirse otarafın sesi karşı ulaşmıyor. dosya transferini kestiginizde herşey normale dönüyor. paketler iki tarfatada match oluyor. yardımlarınız için teşekkürler.
     
     
    merkez router
     
    class-map voip
      match access-group 101
    !
    !
    policy-map qos
      class voip
       bandwidth percent 50
      class class-default
       fair-queue
    !
    ip subnet-zero
    !
    !
    !
    !
    voice-port 1/0
     cptone TR
    !
    voice-port 1/1
     cptone TR
    !
    voice-port 2/0
     cptone TR
    !
    voice-port 2/1
     cptone TR
    !
    !
    dial-peer voice 1 pots
     destination-pattern 35
     port 1/0
    !
    dial-peer voice 2 pots
     destination-pattern 35
     port 1/1
    !
    dial-peer voice 3 pots
     destination-pattern 35
     port 2/0
    !
    dial-peer voice 4 pots
     destination-pattern 35
     port 2/1
    !
    dial-peer voice 5 voip
     destination-pattern 06
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 6 voip
     destination-pattern 06
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 7 voip
     destination-pattern 36
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 8 voip
     destination-pattern 36
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 11 voip
     destination-pattern 34
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    dial-peer voice 12 voip
     destination-pattern 34
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    !
    interface Serial0
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     load-interval 30
     service-policy output qos
     frame-relay lmi-type ansi
    !
    interface Serial0.16 point-to-point
     bandwidth 128
     ip address 192.168.254.1 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 101
      class voipovfr128
     frame-relay ip rtp header-compression
    !
    interface Serial0.17 point-to-point
     bandwidth 64
     ip address 192.168.254.5 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 102
      class voipovfr64
     frame-relay ip rtp header-compression
    !
    interface Serial0.18 point-to-point
     bandwidth 64
     ip address 192.168.254.9 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 103
      class voipovfr64
     frame-relay ip rtp header-compression
    !
    interface FastEthernet0
     ip address 10.9.4.200 255.255.255.0
     no keepalive
     speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.9.4.99
    ip route 10.9.101.0 255.255.255.0 Serial0.16
    ip route 10.9.102.0 255.255.255.0 Serial0.17
    ip route 10.9.103.0 255.255.255.0 Serial0.18
    no ip http server
    !
    !
    map-class frame-relay voipovfr128
     frame-relay cir 128000
     frame-relay bc 1280
     frame-relay be 0
     frame-relay mincir 128000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 160
     frame-relay ip rtp priority 16384 16383 48
    !
    map-class frame-relay voipovfr64
     frame-relay cir 64000
     frame-relay bc 640
     frame-relay be 0
     frame-relay mincir 64000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 80
     frame-relay ip rtp priority 16384 16383 24
    access-list 101 permit udp any any range 16384 32768
    access-list 101 permit ip any any precedence critical
    access-list 101 permit ip any any dscp ef
    access-list 101 permit ip any any precedence flash
     
     
    ankara router;
     
    class-map voip
      match access-group 101
    !
    !
    policy-map qos
      class voip
       bandwidth percent 50
      class class-default
       fair-queue
    !
    memory-size iomem 40
    ip subnet-zero
    !
    !
    !
    !
    voice-port 1/0
     cptone TR
     description ankara_fxs_c/o_no:06
    !
    voice-port 1/1
     cptone TR
     description ankara_fxs_c/o_no:06
    !
    !
    dial-peer voice 1 pots
     destination-pattern 06
     port 1/0
    !
    dial-peer voice 2 pots
     destination-pattern 06
     port 1/1
    !
    dial-peer voice 5 voip
     destination-pattern 06
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 6 voip
     destination-pattern 06
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 7 voip
     destination-pattern 36
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 8 voip
     destination-pattern 36
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 9 voip
     destination-pattern 35
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.5
    !
    dial-peer voice 10 voip
     destination-pattern 35
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.5
    !
    dial-peer voice 11 voip
     destination-pattern 34
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    dial-peer voice 12 voip
     destination-pattern 34
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    !
    interface Serial0
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay lmi-type ansi
    !
    interface Serial0.102 point-to-point
     bandwidth 64
     ip address 192.168.254.6 255.255.255.0
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 102
      class voipovfr64
     frame-relay ip rtp header-compression
    !
    interface FastEthernet0
     ip address 10.9.102.200 255.255.255.0
     no keepalive
     speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.102
    no ip http server
    !
    !
    map-class frame-relay voipovfr64
     frame-relay cir 64000
     frame-relay bc 640
     frame-relay be 0
     frame-relay mincir 64000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 80
     frame-relay ip rtp priority 16384 16383 24
    !
    map-class frame-relay voipovfr128
     frame-relay cir 128000
     frame-relay bc 1280
     frame-relay be 0
     frame-relay mincir 128000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 160
     frame-relay ip rtp priority 16384 16383 48
    access-list 101 permit udp any any range 16384 32768
    access-list 101 permit ip any any precedence critical
    access-list 101 permit ip any any dscp ef
    access-list 101 permit ip any any precedence flash
    !
    line con 0
     transport input none
    line aux 0
    line vty 0 4
     password 7 105A1C1D001A
     login
    !
    end
     

    -----Original Message-----
    From: Ali KAPTAN [mailto:ali.kaptan_at_asay.com.tr]
    Sent: Saturday, November 01, 2003 11:11 AM
    To: cisco-ttl_at_yahoogroups.com
    Subject: RE: [cisco-ttl] qos problemi

    elimdeki routerların ios versiyonu eski ve upgrade yapmak için flash ve ram istiyor. ben elimdeki ios ile map-class frame-relay içinden service policy komutunu çalıştıramıyorum. elimdeki ios ile önerebileceginiz konfigürasyon varmı?
    aslında problem şurda ben dosya transfer etmedigimde ses düzgün çalışıyor fakat merkezden uca dosya transferine başladıgımda ses gidiyor. paketlerin match oldugunuda görüyorum.
     
    rizmir#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C1700 Software (C1700-SV3Y-M), Version 12.1(3b), RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 07-Feb-02 03:21 by yiyan
    Image text-base: 0x80008088, data-base: 0x8083F2F8
     
    ROM: System Bootstrap, Version 12.0(3r)T1, RELEASE SOFTWARE (fc1)
     
    rizmir uptime is 19 hours, 7 minutes
    System returned to ROM by power-on
    System image file is "flash:c1700-sv3y-mz.121-3b.bin"
     
    cisco 1750 (MPC860) processor (revision 0x801) with 29492K/3276K bytes of memory.
    Processor board ID JAD054200VY (3523703939), with hardware revision 0000
    M860 processor: part number 0, mask 32
    Bridging software.
    X.25 software, Version 3.0.0.
    1 FastEthernet/IEEE 802.3 interface(s)
    1 Serial(sync/async) network interface(s)
    4 Voice FXS interface(s)
    32K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
     
    Configuration register is 0x2102
     
    rizmir#
    rizmir#
    rizmir#
    rizmir#sh po
    rizmir#sh policy-map int s0
     Serial0 output : qos
      Weighted Fair Queueing
        Class voip
          Strict Priority
          Output Queue: Conversation 264
            Bandwidth 500 (kbps) Packets Matched 141194
            (pkts discards/bytes discards) 0/0
        Class class-default
          Flow Based Fair Queueing
          Maximum Number of Hashed Queues 256 Max Threshold 64 (packets)
    rizmir#

    -----Original Message-----
    From: gokhans_at_koc.net [mailto:gokhans_at_koc.net]
    Sent: Friday, October 31, 2003 5:44 PM
    To: cisco-ttl_at_yahoogroups.com
    Subject: RE: [cisco-ttl] qos problemi

    Selam,
     
    FRTS kullanıp map-class icinden service policy'i cagırmani onerebilirim.
     
    IP RTP Priority ve LLQ'yu aynı anda kullanırsan PQ'nun önceliği var.Sanırım 12.2.10b'den sonra LLQ CRTP aware oldu.IOS'ın daha yeni bir IOS ise iki feature'dan birini kullanabilirsin.
     
    Ana interface'de traffic shaping girdikten sonra herhangi bir sub-if e class uygulamazsan default olarak 56K ya shape ediyor.Buna dikkat etmek lazım.
     
    Uç Noktadaki routerda map-class'ın içinde frame-relay voice bandwidth komutu gereksiz,sonucta VOFR yapmıyosun.
     
    Dial Peerların içindeki req-qos guaranteed-delay komutununda RSVP kullanmadıgın için bir anlamı yok.
     
     
    Şöyle bir config olabilir mesela :
     
    policy-map qos
      class voip
       priority percent 50
      class class-default
       fair-queue
     
    map-class frame-relay voipovfr128
     frame-relay cir 128000
     frame-relay bc 1280
     frame-relay be 0
     frame-relay mincir 128000
     no frame-relay adaptive-shaping
     service-policy output qos
     frame-relay fragment 160 (64K için 80 )
     frame-relay ip rtp priority 16384 16383 48
     
    map-class frame-relay voipovfr64
     frame-relay cir 64000
     frame-relay bc 640
     frame-relay be 0
     frame-relay mincir 64000
     no frame-relay adaptive-shaping
     service-policy output qos
     frame-relay fragment 80
    frame-relay ip rtp priority 16384 16383 24
     
    interface Serial0
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     load-interval 30
     frame-relay traffic-shaping
     frame-relay lmi-type ansi
    !
    interface Serial0.16 point-to-point
     bandwidth 128
     ip address 192.168.254.1 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     frame-relay interface-dlci 101
     class voipovfr128
     frame-relay ip rtp header-compression
    !
    interface Serial0.17 point-to-point
     bandwidth 64
     ip address 192.168.254.5 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     frame-relay interface-dlci 102
     class voipovfr64
     frame-relay ip rtp header-compression

     
     
     
     
    Gokhan Surucu
    CCIE#12161
     
     

    -----Original Message-----
    From: Ali KAPTAN [mailto:ali.kaptan_at_asay.com.tr]
    Sent: Friday, October 31, 2003 4:56 PM
    To: cisco-ttl_at_yahoogroups.com
    Subject: [cisco-ttl] qos problemi

        arkadaşlar selamlar bir müşterimin 3 bölgesinde qos çalıştırmaya çalışıyorum. hatlar frame-relay. routerlar üzerinde çeşitli ayarlar yaptım fakat problem şuki merkezden bölgeye dosya transfer edilmeye başladıgında voice gidiyor ama ben peketlerin match edildigini görüyorum. daha önce bununla ugraşan varmı???
     
     
    merkez router
        Current configuration:
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname rizmir
    !

    !

    !
    class-map voip
      match access-group 101
    !
    !
    policy-map qos
      class voip
        priority 500
      class class-default
       fair-queue
    !
    ip subnet-zero
    !
    !
    !
    !
    voice-port 1/0
     cptone TR
    !
    voice-port 1/1
     cptone TR
    !
    voice-port 2/0
     cptone TR
    !
    voice-port 2/1
     cptone TR
    !
    !
    dial-peer voice 1 pots
     destination-pattern 35
     port 1/0
    !
    dial-peer voice 2 pots
     destination-pattern 35
     port 1/1
    !
    dial-peer voice 3 pots
     destination-pattern 35
     port 2/0
    !
    dial-peer voice 4 pots
     destination-pattern 35
     port 2/1
    !
    dial-peer voice 5 voip
     destination-pattern 06
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 6 voip
     destination-pattern 06
     dtmf-relay cisco-rtp
     req-qos guaranteed-delay
     ip precedence 5
     session target ipv4:192.168.254.6
    !
    dial-peer voice 7 voip
     destination-pattern 36
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 8 voip
     destination-pattern 36
     dtmf-relay cisco-rtp
     req-qos controlled-load
     ip precedence 5
     session target ipv4:192.168.254.2
    !
    dial-peer voice 11 voip
     destination-pattern 34
     dtmf-relay cisco-rtp
     req-qos guaranteed-delay
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    dial-peer voice 12 voip
     destination-pattern 34
     dtmf-relay cisco-rtp
     req-qos guaranteed-delay
     ip precedence 5
     session target ipv4:192.168.254.10
    !
    !
    interface Serial0
     no ip address
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     load-interval 30
     service-policy output qos
     frame-relay lmi-type ansi
    !
    interface Serial0.16 point-to-point
     bandwidth 128
     ip address 192.168.254.1 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 101
     frame-relay ip rtp header-compression
    !
    interface Serial0.17 point-to-point
     bandwidth 64
     ip address 192.168.254.5 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 102
     frame-relay ip rtp header-compression
    !
    interface Serial0.18 point-to-point
     bandwidth 64
     ip address 192.168.254.9 255.255.255.252
     no ip route-cache
     no ip mroute-cache
     service-policy output qos
     frame-relay interface-dlci 103
     frame-relay ip rtp header-compression
    !
    interface FastEthernet0
     ip address 10.9.4.200 255.255.255.0
     no keepalive
     speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.9.4.99
    ip route 10.9.101.0 255.255.255.0 Serial0.16
    ip route 10.9.102.0 255.255.255.0 Serial0.17
    ip route 10.9.103.0 255.255.255.0 Serial0.18
    no ip http server
    !
    !
    map-class frame-relay voipovfr128
     frame-relay cir 128000
     frame-relay bc 1280
     frame-relay be 0
     frame-relay mincir 128000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 320
     frame-relay ip rtp priority 16384 16383 48
    !
    map-class frame-relay voipovfr64
     frame-relay cir 64000
     frame-relay bc 640
     frame-relay be 0
     frame-relay mincir 64000
     no frame-relay adaptive-shaping
     frame-relay fair-queue
     frame-relay fragment 320
    access-list 101 permit udp any any range 16384 32768
    access-list 101 permit ip any any precedence critical
    snmp-server engineID local 000000090200000653BE8259
    snmp-server community asay RO
    alias exec dlci sh fram pvc | inc Serial
    alias exec ses sh call active voice brief
    !
    line con 0
     transport input none
    line aux 0
    line vty 0
     password 7 1403070F0909
    line vty 1 4
    !
    end
     
    rizmir#
     
    uç noktalardan biri
     
     
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    !
     class-map match-all voip
      match access-group 101
    !
    !
     policy-map qos
      class voip
       priority percent 50
      class class-default
       fair-queue
    !
    !
    !
    interface FastEthernet0
     ip address 10.9.101.200 255.255.255.0
     speed auto
     half-duplex
     no keepalive
    !
    interface Serial0
     no ip address
     service-policy output qos
     encapsulation frame-relay
     no ip route-cache
     no ip mroute-cache
     frame-relay lmi-type ansi
    !
    interface Serial0.101 point-to-point
     bandwidth 128
     ip address 192.168.254.2 255.255.255.0
     no ip route-cache
     no ip mroute-cache
     frame-relay interface-dlci 101
     frame-relay ip rtp header-compression
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.101
    no ip http server
    !
    !
    !
    map-class frame-relay voipovfr128
     frame-relay cir 128000
     frame-relay bc 1280
     frame-relay be 0
     frame-relay mincir 128000
     frame-relay fair-queue
     frame-relay voice bandwidth 64000
     frame-relay fragment 320
    access-list 101 permit udp any any range 16384 32768
    access-list 101 permit ip any any precedence critical
    !
    !
    voice-port 1/0
     cptone TR
    !
    voice-port 1/1
     cptone TR
    !
    !
    dial-peer voice 1 pots
     destination-pattern 36
     port 1/0
    !
    dial-peer voice 2 pots
     destination-pattern 36
     port 1/1
    !
    dial-peer voice 5 voip
     destination-pattern 35
     session target ipv4:192.168.254.5
     dtmf-relay cisco-rtp
     req-qos guaranteed-delay
     ip qos dscp cs5 media
    !
    dial-peer voice 6 voip
     destination-pattern 35
     session target ipv4:192.168.254.5
     dtmf-relay cisco-rtp
     req-qos guaranteed-delay
     ip qos dscp cs5 media
    !
    dial-peer voice 7 voip
     destination-pattern 06
     session target ipv4:192.168.254.6
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !
    dial-peer voice 8 voip
     destination-pattern 06
     session target ipv4:192.168.254.6
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !
    dial-peer voice 9 voip
     destination-pattern 34
     session target ipv4:192.168.254.10
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !
    dial-peer voice 10 voip
     destination-pattern 34
     session target ipv4:192.168.254.10
     dtmf-relay cisco-rtp
     ip qos dscp cs5 media
    !
    !
    line con 0
     exec-timeout 0 0
    line aux 0
    line vty 0 4
     password 7 001006020156
     login
    !
    no scheduler allocate
    !
    end
     
    depo#
     
     

    Bu listenin Cisco Systems ile dogrudan herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.

    Your use of Yahoo! Groups is subject to the Yahoo! Terms of <http://docs.yahoo.com/info/terms/> Service.

    Bu listenin Cisco Systems ile dogrudan herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.

    Your use of Yahoo! Groups is subject to the Yahoo! Terms of <http://docs.yahoo.com/info/terms/> Service.

    Bu listenin Cisco Systems ile dogrudan herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.

    Your use of Yahoo! Groups is subject to the Yahoo! Terms of <http://docs.yahoo.com/info/terms/> Service.

    Yahoo! Groups Sponsor

    ADVERTISEMENT
     <http://rd.yahoo.com/M=267637.4116730.5333196.1261774/D=egroupweb/S=1705004726:HM/A=1754452/R=0/SIG=11tn6fnpm/*http://www.netflix.com/Default?mqso=60178324&partid=4116730ick here
      <http://us.adserver.yahoo.com/l?M=267637.4116730.5333196.1261774/D=egroupmail/S=:HM/A=1754452/rand=193764897>

    Bu listenin Cisco Systems ile dogrudan herhangi bir baglantisi bulunmamaktadir.

    Listeden cikmak için cisco-ttl-unsubscribe_at_yahoogroups.com adresine bir e-posta gönderebilirsiniz.

    Your use of Yahoo! Groups is subject to the Yahoo! Terms of <http://docs.yahoo.com/info/terms/> Service.



    This archive was generated by hypermail 2.1.5 : Mon Nov 03 2003 - 16:30:16 GMT