Re: [cisco-ttl] Paketleriı Farklı iki lokasyona Farklı Source Ip adresleri olarak Göndermek.

From: Ilker Temir ([email protected])
Date: Thu Jan 30 2003 - 07:23:11 GMT

  • Next message: Engin ZEREN: "Re: [cisco-ttl] Paketleriı Farklı iki lokasyona Farklı Source Ip adresleri olarak Göndermek."

    access-list 150 permit ip host 10.1.1.1 host 172.16.2.1
    access-list 160 permit ip host 10.1.1.1 host 172.16.3.1

    ip nat pool ABANK 10.2.2.2 10.2.2.2.2 netmask 255.255.255.0
    ip nat pool BBANK 10.3.3.3 10.3.3.3 netmask 255.255.255.0

    ip nat inside source list 150 pool ABANK overload
    ip nat inside source list 160 pool BBANK overload

    Yalniz bir kucuk nokta, ilk mesajiniz ile bu mesajinizda sordugunuz
    sorularda bir tur celiski var. Yukaridaki turde bir yapilandirma, sizin
    tarafinizdaki istemcilerin kaynak IP'lerini degistirmek icin calisir ama
    eger sorunuz kendi tarafinizdaki bir sunucunun bankalardan ulasimi ise (ilk
    sorunuzu ben bu yonde algiladim) bu yapilandirma isinize yaramayacaktir.

    Ayrica policy routing kullanmaniz gerekmiyor, iki statik tanim yeterli.

    Ilker

    ----- Original Message -----
    From: "Engin ZEREN" <[email protected]>
    To: <[email protected]>
    Sent: Thursday, January 30, 2003 10:05 AM
    Subject: Re: [cisco-ttl] Paketleriı Farklı iki lokasyona Farklı Source Ip
    adresleri olarak Göndermek.

    > Merhaba,
    > İşte problem burada çıkıyor. Göndermiş olduğunuz konfigurasyonda
    "interface
    > Serial5/0:11" bağlantısı olsun. Bu bağlantının B bankası ile yapıldığını
    > farz edelim.
    > Bu interface altında ip nat outside dediğimizde B bankasına giden
    > paketlerimiz A bankasına gidenler gibi "overld" pool undan ip alıp
    > çıkacaklar.
    > Hangi yöntem ile farklı interfacelerin farklı pool lardan nata uğrayıp
    > çıkmasını sağlayabiliriz?
    > Ben route map komutu ile deneme yaptım ancak istediğim yapı olmadı. Amacım
    > farklı destinationlar için farklı poolardan NAT ile çıkarmak. İlk problem
    > ethernet altına aynı anda iki policy tanımlayamamakla başlıyor. Tanımları
    > aynı access-list altına yapsam bu sefer NAT pool ları ayıramıyorum.
    > Yaptığım örnek konfigurasyon şu şekilde :
    >
    > server : 10.1.1.1
    > A bankası için NAT : 10.2.2.2
    > B bankası için NAT : 10.3.3.3
    > A bankası senkron IP : 192.168.2.1/30
    > B bankası senkron IP : 192.168.3.1/30
    > A bankasında ulaşılan server : 172.16.2.1
    > B bankasında ulaşılan server : 172.16.3.1
    > !!!!!!!!!!!!!!!!!!!!!!!!
    > ip nat pool ABANK 10.2.2.2 10.2.2.2.2 netmask 255.255.255.0
    > ip nat inside source list 150 pool ABANK overload
    > access-list 150 permit ip host 10.1.1.1 host 172.16.2.1
    >
    > route-map ABANK permit 10
    > match ip address 150
    > set ip next-hop 192.168.2.1
    >
    > ip nat pool BBANK 10.3.3.3 10.3.3.3 netmask 255.255.255.0
    > ip nat inside source list 160 pool BBANK overload
    > access-list 160 permit ip host 10.1.1.1 host 172.16.3.1
    >
    > route-map BBANK permit 10
    > match ip address 160
    > set ip next-hop 192.168.3.1
    >
    > interface fastethernet0/0
    > ip address 10.1.1.2 255.255.255.0
    > ip policy route-map ABANK
    > ! ip policy route-map BBANK
    > ip nat inside
    >
    > interface serial 1/0
    > description CONNECTION TO ABANK
    > ip address x.x.x.x x.x.x.x
    > ip nat outside
    >
    > interfacec serial 1/1
    > description CONNECTION TO BBANK
    > ip address x.x.x.x x.x.x.x
    > ip nat outside
    >
    >
    > ip route 172.16.2.1 255.255.255.255 serial 1/0
    > ip route 172.16.3.1 255.255.255.255 serial 1/1
    > !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    >
    > Bu durumda ne yapabilirim İyi çalışmalar ...
    >
    > ******************************
    > Engin ZEREN
    >
    >
    >
    > ----- Original Message -----
    > From: "Ilker Gokhan" <[email protected]>
    > To: <[email protected]>
    > Sent: Thursday, January 30, 2003 9:38 AM
    > Subject: Re: [cisco-ttl] Paketleriı Farklı iki lokasyona Farklı Source Ip
    > adresleri olarak Göndermek.
    >
    >
    > > Engin ZEREN wrote:
    > > > Merhaba,
    > > > 10.1.1.1 serverindan gelen paketleri A bankası 10.2.2.2 şeklinde B
    > > > bankası ise 10.3.3.3 şeklinde görmek istiyor.
    > > > 10.1.1.1 serverının A ve B bankaları ile aynı router üzerinde
    > > > farklı seri interfacelerden LL bağlantıları var.
    > > > Bunu NAT ile nasıl yapabilirim.?
    > > > İyi çalışmalar ....
    > >
    > > Sadece A icin bir ornek bunu revize ederek kullanabilirsin.. Hmm bir de
    > > ikinci bir lokasyon farkli bir adreste gorecek ? bunu daha once
    > > yapmamistim ama "ip nat pool" satirinda pool degilde diger opsiyonlara
    > > bir bakmak gerekiyor sanirim.
    > >
    > > !
    > > interface FastEthernet0/0
    > > ip address 10.5.1.1 255.255.255.0
    > > ip nat inside
    > > duplex auto
    > > speed auto
    > > !
    > > ip nat pool ovrld <Donuturmek istedigin IP adresi baslangici>
    > > <Donuturmek istedigin IP adresi baslangici> prefix-length 24
    > > ip nat inside source list 7 pool ovrld overload
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 10.5.1.3
    > > ip route 10.0.0.0 255.0.0.0 10.5.1.4 250
    > > ip route 10.1.4.0 255.255.255.0 10.5.1.3
    > > ip route 89.0.0.0 255.0.0.0 Serial5/0:10
    > >
    > > !
    > > access-list 7 permit 10.1.1.1 0.0.0.0
    > >
    > > !
    > > interface Serial5/0:10
    > > description A bankasi
    > > bandwidth 64
    > > ip address x.x.x.x x.x.x.x
    > > ip nat outside
    > > ip mroute-cache
    > >
    > > Saygilar..
    > > Ilker G.
    > > --------
    > > http://istanbul.linux.org.tr/~ilkerg/
    > >
    > >
    > > Bu listden çıkmak için [email protected] adresine
    bir
    > e-posta göndermeniz yeterlidir.
    > >
    > >
    > >
    > > Your use of Yahoo! Groups is subject to
    http://docs.yahoo.com/info/terms/
    > >
    > >
    > >
    >
    >
    > Bu listden çıkmak için [email protected] adresine bir
    e-posta göndermeniz yeterlidir.
    >
    >
    >
    > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
    >
    >

    Bu listden çıkmak için [email protected] adresine bir e-posta göndermeniz yeterlidir.

     

    Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/



    This archive was generated by hypermail 2.1.5 : Thu Jan 30 2003 - 11:24:27 GMT